eruthros: Aang from Avatar:TLA facepalming (Avatar - facepalming aang)
[personal profile] eruthros
I know a lot of y'all don't use lj, but in case you do, there seems to be a bug that caused (is causing?) a security/privacy breach: multiple people have reported that when they try to edit their own entries/profile/inbox, they are taken to another random user's edit entries/profile/inbox page, and can see all of that user's flocked and private entries. Basically, the system seems to think that they're logged in as another user. Here are some of the early bug reports from last night:

cocanuts reports the logged-in-as-another-user bug
itsaserket reports the logged-in-as-another-user bug
rachelmanija reports the same bug (and also reports that it stopped happening to her) (ETA: she expanded on what the bug looked like in comments here)
nix_this reports the same bug (with other details in nix_this's lj)
kazzisato reports the same bug

... but there are a ton of comments on the lj releases post now; those are just the first reports of the problem that I saw. LJ staff have not yet commented to my knowledge, so all that there is so far is a series of bug reports - nobody seems to know the extent or scale of the problem, whether it was a temporary glitch that has already been fixed or whether it's ongoing, or basically any other details. I haven't seen any bug reports from users who noticed unauthorized access of their journals - just from people who noticed being logged in as someone else.

There's also an overview post about this lj bug at unfunnybusiness. There don't seem to be any suggestions for fixes yet, but the lj release entry for their recent code release has 800+ comments and is growing, and I haven't looked at everything. I haven't seen any reports on why it's happening, but some folks are suggesting that it might be related to an (unannounced) change in handling cookies that has also affected plugins like LJ Login and dreamwidth's comment importing.

Unfortunately, while you can tell pretty easily if you have access to the wrong journal (click edit entries, see what happens, if something goes wrong log out and log back in), so far there's no way to tell if anyone else has access to yours. Will ETA if I learn more.

ETA1: I haven't seen any bug reports from people who experienced the bug after mid-morning today UTC (but I could have just missed them) - if you know of any, please let me know and I'll ETA again. Now I've seen some more recent reports, so it hasn't stopped happening. I have also seen people reporting that it's no longer happening to them, though - [personal profile] rachelmanija, linked above, and [personal profile] wendelah1 in comments here.

ETA2: [ profile] fallacy_angel took a screencap of the journal they were temporarily logged into; see also their comment at lj releases.

ETA3: Strike ETA1; I think [ profile] dapperdinosaur is reporting the bug shortly after it happened to them, which makes a bug report from about 4:00 am UTC on the 27th.

ETA4: [personal profile] lorax experienced the bug at about 3:15 pm UTC on the 26th, and wrote up an detailed report of what the bug looked like plus some notes about lj's response.

ETA5: In the comments here, [personal profile] silveraspen describes the response to their pm to a site staffer (at 2:46 pm UTC on the 27th) which suggested that info was going to go up at [ profile] lj_maintenance soonish.

ETA6: There's a new lj maintenance post that describes the problem: they're saying that it didn't allow people to edit other users' pages, just view them, so it wasn't a security risk. (This is one of the times when I facepalm about lj's communication - site security vs security of people's info would maybe have been a good thing to mention there.) They also describe it as a bug that lasted for only three minutes - while it's true that most of the bug reports I saw were clustered around the same time period, I've also seen a couple more recent reports, so that seems ... unlikely.

ETA7: Make that a really recent one - here's [ profile] snailbones's report of the problem happening after that lj maintenance post was made.

ETA8: This is the first instance I've seen of someone saying that they actually did something with the account they were logged into (I think - it's somewhat confusingly worded, so definitely grain of salt here), plus some discussion of how long the problem was happening: [ profile] misstiajournal's comment at the lj maintenance post.

ETA9: [ profile] moropus also reports that they accidentally commented as another user when they experienced the bug (note that the comment also has anti-Russian sentiment)

ETA10: [personal profile] siljamus talks about things to do to minimize the risk of this happening to your journal, which mostly involve logging out of all of your livejournal login sessions, and then not logging back in at all (which includes not crossposting from dw).

ETA11: I haven't seen a live report of the bug since [personal profile] snailbones's, linked above, at 9:38 pm UTC on the 27th. Anyone else seen anything? Yup, other people have seen something - see ETA14.

ETA12: LJ mentioned the problem in passing in their most recent lj news update; many of the comments are angry about the in-passing remark, wording, challenge the details, etc.

ETA13: [personal profile] rachelmanija describes what the bug looked like (what she could see, how long it lasted).

ETA14: strike ETA11; [personal profile] majoline reports seeing the bug (or a different bug?) at about 3:30 pm UTC on 10/29. This bug report is different, though - they were taken to the edit entries page of a journal entry they clicked on, not to a random journal. No word on whether they could do anything on that page. [personal profile] majoline commented to say that the buttons were grayed out and couldn't be clicked on.

ETA15: It turns out that anyone can see anyone else's edit-entry page for a public post by putting in their username and the number of the entry; it only works for public posts, and it grays out the boxes and nothing can be clicked on. So a misdirected link could send someone there, and so could I if I manually entered it, and etc. [personal profile] darkspirited1 and [personal profile] xenotaku have been figuring out the parameters of how this works in a comment thread. The existence of this weird UI is irritating, because it means that the cache error(?) bug and this thing might be described in the same way by a user. The important differences seem to be that in the cache error, someone appeared to be logged in as someone else, so the edit entry page would appear normally but with someone else's data (buttons appeared pushable, someone else's username and icon, etc), whereas in this edit entry page looks weird and unusuable (buttons and text greyed out, at the top it looks like you're trying to edit a post in a community: [yourusername] in community [otherjournalname]).

ETA16 I just saw another new bug report on lj maintenance of something weird that looks a bit like the original bug circa 4:53 pm UTC 10/29. Their comment with screencaps got marked suspicious, but since the comment was emailed to me I saw the screencap, and they said I could link it here: screencap of the post entries page as [ profile] snowsoftsong. It looks like the post entries page as if someone else was viewing it - there was no "in community..." or anything and the entry page wasn't greyed out - except that the username was [ profile] snowsoftsong, and the original poster of that post was alwaystheheart in a different comm. So: WEIRD.

(Almost) everything I've linked to in this post is a single user's bug report or description of their issues - I have no way of checking the veracity of anyone's comments.

Date: 2011-10-30 02:59 am (UTC)
darkspirited1: brown wolf staring off into space (Default)
From: [personal profile] darkspirited1
Hey. I've been following your blog and the updates. I'm really grateful to them! They've helped keep me in the loop. I'm still a little confused as to whether LJ has officially stopped this. I can say that I did do a little digging and try to find out with some personal research.

It's a long comment, so basically, tl;dr: Turns out you can access a public entry edit page with the simple edit entry url for each entry, but not private, friends only, profiles, or inboxes NOW as far as I can tell. What things were like before is another story...

The longer story:

I have a few old journals I no longer use on LJ that were perfect for such a cause. We shall call them APost and AView. I use AView to try to look into APost entries. APost is a blank journal I created a while back but never used. I made 3 entries, one public, one private, and one friends only.

I tried to access each one with the standard edit entry URL and gained access to ONLY the public entry in APost.

However, it does NOT allow me to change ANYTHING on APost. Everything is sort of grayed out. It will NOT allow me to even view the private and friends only entries. Thank goodness!

I also tried accessing the edit profile URL for my test account and it came up with an error saying I couldn't be verified as the user. Trying to access a message from my inbox came up with that error too.

Both journals are on different servers.

I tell you this information in hopes that it might somehow bring some insight to anyone who still worries about this security breach.

However, I should also mention that looking at the login information under manage/logins.bml on the APost does NOT show that I "logged in". In fact, when I was viewing APost through AView, it showed me as if I was trying to edit a post in a community oddly enough. Specifically it says:

Poster: [userhead image] in community [userhead] [APost]

It also shows AView's userpic but does not list AView as the poster. It's just a userpic.

It will be nice to see if LJ makes any further comments regarding this issue.

Sorry for making this comment so long. I actually have screenshots of everything too if you want to see them/things are too difficult to understand here.

Date: 2011-10-30 04:39 pm (UTC)
xenotaku: Luc from Suikoden (Luc | Studying)
From: [personal profile] xenotaku
Just tried it out myself, and got the same results (for editing journal entries, at least). For the f-locked and private entries, it told me "could not find journal entry". For the public one, it gave me a grayed-out edit box and buttons, the weird "Poster:" line, and it shows my logged-in icon and icon list.

Date: 2011-10-30 05:10 pm (UTC)
xenotaku: Omi from Weiss Kreuz (Omi | Goggles)
From: [personal profile] xenotaku
Huh, so maybe this isn't related to the other bug? Since you're not appearing as logged in, like the other bug's reports are saying.

At least I know that people can't purposefully get into my locked entries, or edit my journal. Accidentally, on the other hand...

BTW, just tried it with a public community post, and it's giving me the "Could not find selected journal entry", so it doesn't even work to view the edit page with a community post.

Date: 2011-10-30 05:19 pm (UTC)
darkspirited1: brown wolf staring off into space (Default)
From: [personal profile] darkspirited1
I wonder why it doesn't work with communities?

Date: 2011-10-30 05:22 pm (UTC)
xenotaku: Omi from Weiss Kreuz (Omi | Goggles)
From: [personal profile] xenotaku
Dunno, but I tried it with a public entry with a journal each member and non-member, and I couldn't access the page with either.

Date: 2011-10-30 09:05 pm (UTC)
From: (Anonymous)
I've found you can load a community entry into the community edit form, in the same way you can load a user entry into the user edit form. But you can't load a comm entry into a user edit form or a user entry into a comm edit form, because the forms are different and presumably the query that loads the entry gets a malformed response from the slightly different permissions that operate in communities unless the right form is used.

I'm not sure I'd even call the ability to do this a bug, given that you can't save or view anything you shouldn't, it's really just forcing a form to show content you can view anyway using a slightly different template.

The thing that sounds like a bug is whatever it is that is redirecting people to the forms in such a way that they see the wrong content and think they have the ability to edit other people's journals, because that's clearly causing panic.

I am wondering if this problem is actually linked to having a broken lj-login install on the browser - I think that may also be linked to the problems where LJ keeps logging people out? Just a theory but I tried to replicate this problem and was unable to do so.

It would certainly be a polite and commercially astute move if LJ could offer lj-login assistance in getting their plugin working asap, particularly if the broken plugin is causing people to think there are other problems.

Sorry, I don't have a dw so this will be screened. I assume someone will be able to unscreen it if it seems helpful.

Date: 2011-10-30 05:19 pm (UTC)
darkspirited1: brown wolf staring off into space (Default)
From: [personal profile] darkspirited1
DW does it too? That's so strange! Bugs are intriguing!

Date: 2011-10-30 05:25 pm (UTC)
darkspirited1: brown wolf staring off into space (Default)
From: [personal profile] darkspirited1
DW is a little more interesting because you can actually type in the box and change everything. There's just no save button. The delete button also doesn't work.

Date: 2011-10-30 05:18 pm (UTC)
darkspirited1: brown wolf staring off into space (Default)
From: [personal profile] darkspirited1
Ah yes. I hadn't seen the support request. I'm just glad you can't look into friends only/private entries like that.

Still, I wish LJ would announce whether the random happenings have stopped. This makes me think that they may have, at least in the case of private/friends only stuff. One can only hope anyway...

Date: 2011-10-30 05:41 pm (UTC)
darkspirited1: brown wolf staring off into space (Default)
From: [personal profile] darkspirited1
Could they edit it like in DW but just not save/delete it?

Date: 2011-10-30 06:02 pm (UTC)
From: (Anonymous)
This will be screened, but: I'm the user with the caps.

The page it took me to was the basic update page for posting, all I got was someone's saved draft. I removed all that data from the text box and posted to my own journal with success. My post had my own information that I put it, and their post was left unchanged, so I didn't have access to anything in their actual account, just their saved draft.

Date: 2011-10-30 07:26 pm (UTC)
briar_pipe: knight lowering his lance to charge (Jousting)
From: [personal profile] briar_pipe
This bug is very old on both sites.

I switch constantly between accounts, some of which are shared. I often end up viewing an "edit entry" page for an entry I didn't post with that account. I can't actually edit or delete it, but I can view it. It's very similar to the way a mod can view entries on a comm in edit mode but can't actually edit them, except instead of the textbox being grayed out and the meta options available, the textbox is regular and the post and delete options are not available.

Here via [personal profile] lorax.


eruthros: Delenn from Babylon 5 with a startled expression and the text "omg!" (Default)

May 2017

2829 3031   

Expand Cut Tags

No cut tags
Page generated Oct. 22nd, 2017 10:03 am
Powered by Dreamwidth Studios